Apr 11, 2011

Ubuntu Software Center's error on 11.04 Natty Narwhal with DraftSight

Starting with 10.10 Maverick Meerkat, Ubuntu uses by default Ubuntu Software Center for the installation of standalone deb packages instead of the traditional gdebi application.
This causes an error when attempting to install the DraftSight package. Ubuntu Software Center complains about "bad package's quality" by preventing DraftSight's installation.


I installed DraftSight on Ubuntu 11.04 Natty Narwhal the first day it was released. However I didn't notice this problem because I prefer to use gdebi for the installation of standalone .debs. After a month of testing, DraftSight seems to work well with Ubuntu 11.04 and nVIDIA binary driver. So If you want to skip this error message just install gdebi and use it for the installation of standalone .debs
Right click on your deb package and select "Open with GDebi" option

Or you can use command line:
sudo dpkg -i DraftSight.deb
This workaround is for 32bit Ubuntu 11.04

*Do not forget that for 64bit systems your only option is the command line:
sudo dpkg -i --force-architecture DraftSight.deb
after the installation of any possible missing dependencies. Typically DraftSight needs 2 extra packages:
libdirectfb-extra and libxcb-render-util0

2 comments:

  1. Thank you veru much for this. You solved my problem.

    ReplyDelete